Установка Windows 7 по сети

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 06:28

Имеется Windows Server 2008 R2, ConfigManager 2012 SP1.
Настроил всё по инструкции, развернул WDS, DHCP на одном сервере. В DHCP прописал диапазон адресов, т.к. всё на одном сервере 066 и 067 прописывать не стал. В WDS на вкладке "Протокол DHCP" установил только галочки "Не прослушивать порт 67" и "Задать для параметра DHCP значение 60, что бы указать, что этот сервер так же является PXE-сервером", больше ничего не трогал. При настройке указал путь D:/RemoteInstall. Распространил Boot Image на точку распространения, поставил галочку "Раз. загрузочный образ из точки распр. поддерживающий PXE". Снял эталонный образ с Windows 7 (предварительно загнал в домен, установил клиента конфигменеджера, выгнал и рабочую группу, захватчиком (x64) снял образ, он же слил его по сети), распространил на точку. Создал последовательность задач, образ так же выбрал x64 (x86 тоже пробовал), выбрал образ операционной системы (который снял захватчик). Запустил тестовую машину (виртуальную, на VMware), IP адрес из указанного диапазона она получила, в итоге вышло вот такое:
1.jpg
1.jpg (42.36 КБ) 2763 просмотра
2.jpg
2.jpg (121.01 КБ) 2763 просмотра
В логах SMSPXE написано следующее:

<![LOG[In SSL, but with no client cert]LOG]!><time="15:15:54.463-180" date="10-29-2013" component="SMSPXE" context="" type="1" thread="13556" file="libsmsmessaging.cpp:8755">
<![LOG[In SSL, but with no client cert]LOG]!><time="15:15:54.648-180" date="10-29-2013" component="SMSPXE" context="" type="1" thread="13556" file="libsmsmessaging.cpp:8755">
<![LOG[reply has no message header marker]LOG]!><time="15:15:54.933-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="libsmsmessaging.cpp:1972">
<![LOG[PXE::MP_LookupDevice failed; 0x80004005]LOG]!><time="15:15:54.933-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="database.cpp:249">
<![LOG[In SSL, but with no client cert]LOG]!><time="15:15:55.061-180" date="10-29-2013" component="SMSPXE" context="" type="1" thread="13556" file="libsmsmessaging.cpp:8755">
<![LOG[In SSL, but with no client cert]LOG]!><time="15:15:55.268-180" date="10-29-2013" component="SMSPXE" context="" type="1" thread="13556" file="libsmsmessaging.cpp:8755">
<![LOG[reply has no message header marker]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="libsmsmessaging.cpp:1972">
<![LOG[Failed to send status message (80004005)]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="libsmsmessaging.cpp:4055">
<![LOG[Failed to send the status message]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="database.cpp:457">
<![LOG[PXE::MP_ReportStatus failed; 0x80004005]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="database.cpp:461">
<![LOG[PXE Provider failed to process message.
Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="3" thread="13556" file="pxehandler.cpp:1418">
<![LOG[00:50:56:95:2E:99, 42BC1542-AA59-7B45-1013-4DC5C136F6BF: Not serviced.]LOG]!><time="15:15:55.406-180" date="10-29-2013" component="SMSPXE" context="" type="1" thread="13556" file="database.cpp:479">

Помогите пожалуйста, уже неделю с этим борюсь, ничего не выходит.
Не всегда говори, что думаешь, но всегда думай, что говоришь

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Алексей Максимов » 31 окт 2013 10:46

Проверьте настройки PXE как описано здесь
http://blog.it-kb.ru/2012/07/31/system- ... rver-role/
Проверьте что в свойствах boot образов в SCCM разрешено их использование на PXE.

Аватара пользователя
Виталий Якоб
Администратор сайта
Сообщения: 30
Зарегистрирован: 19 сен 2013 09:52

Re: Установка Windows 7 по сети

Сообщение Виталий Якоб » 31 окт 2013 12:09

В блоге TechNet нашёл статью

На сколько я понимаю, Вам нужно переключить систему сайта на "HTTP и HTTPS" и
снять галку "Использовать сертификат PKI клиента" в свойствах сайта, на вкладке "Взаимодействие с клиентским компьютером".
Так же, нужно зайти в свойства точки распространения и убедится, что сертификаты PKI не используются, а точка распространения работает в режиме HTTP.
Думаю, после этого проблема будет решена.

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 12:33

Алексей Максимов писал(а):Проверьте настройки PXE как описано здесь
http://blog.it-kb.ru/2012/07/31/system- ... rver-role/
Проверьте что в свойствах boot образов в SCCM разрешено их использование на PXE.
Там написано, что:
В Windows Firewall должны появиться соответствующие правила разрешающие входящий трафик UDP для служб WDS
У меня этого не произошло, как их в ручную можно добавить?
1.jpg
1.jpg (142.76 КБ) 2745 просмотров
Не всегда говори, что думаешь, но всегда думай, что говоришь

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 12:39

Виталий Якоб писал(а):В блоге TechNet нашёл статью

На сколько я понимаю, Вам нужно переключить систему сайта на "HTTP и HTTPS" и
снять галку "Использовать сертификат PKI клиента" в свойствах сайта, на вкладке "Взаимодействие с клиентским компьютером".
Так же, нужно зайти в свойства точки распространения и убедится, что сертификаты PKI не используются, а точка распространения работает в режиме HTTP.
Думаю, после этого проблема будет решена.
Тоже самое, наверно дело в брандмауре, хотя я его выключал полностью, проблема не решилась
Не всегда говори, что думаешь, но всегда думай, что говоришь

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Алексей Максимов » 31 окт 2013 12:44

Если правила не появились, то вполне возможно, что установка WDS в процессе включения PXE в свойствах точки распространения прошла как-то некорректно. Проверьте предположения Виталия, и если у вас режим HTTPS не включен, можно просто попробовать отключить поддержку PXE (при этом согласиться на снос WDS), подождать успешного завершения удаления WDS (отследить по эвентлогам), и заново включить PXE, тем самым инициировав процесс повторной установки WDS.

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 12:45

Лог после всех сделанных манипуляций:

<![LOG[In SSL, but with no client cert]LOG]!><time="16:41:12.056-240" date="10-31-2013" component="SMSPXE" context="" type="1" thread="7840" file="libsmsmessaging.cpp:8755">
<![LOG[In SSL, but with no client cert]LOG]!><time="16:41:12.153-240" date="10-31-2013" component="SMSPXE" context="" type="1" thread="7840" file="libsmsmessaging.cpp:8755">
<![LOG[reply has no message header marker]LOG]!><time="16:41:12.213-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="libsmsmessaging.cpp:1972">
<![LOG[PXE::MP_LookupDevice failed; 0x80004005]LOG]!><time="16:41:12.214-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="database.cpp:249">
<![LOG[In SSL, but with no client cert]LOG]!><time="16:41:12.291-240" date="10-31-2013" component="SMSPXE" context="" type="1" thread="7840" file="libsmsmessaging.cpp:8755">
<![LOG[In SSL, but with no client cert]LOG]!><time="16:41:12.404-240" date="10-31-2013" component="SMSPXE" context="" type="1" thread="7840" file="libsmsmessaging.cpp:8755">
<![LOG[reply has no message header marker]LOG]!><time="16:41:12.464-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="libsmsmessaging.cpp:1972">
<![LOG[Failed to send status message (80004005)]LOG]!><time="16:41:12.465-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="libsmsmessaging.cpp:4055">
<![LOG[Failed to send the status message]LOG]!><time="16:41:12.465-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="database.cpp:457">
<![LOG[PXE::MP_ReportStatus failed; 0x80004005]LOG]!><time="16:41:12.465-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="database.cpp:461">
<![LOG[PXE Provider failed to process message.
Unspecified error (Error: 80004005; Source: Windows)]LOG]!><time="16:41:12.465-240" date="10-31-2013" component="SMSPXE" context="" type="3" thread="7840" file="pxehandler.cpp:1418">
<![LOG[00:50:56:95:2E:99, 42BC1542-AA59-7B45-1013-4DC5C136F6BF: Not serviced.]LOG]!><time="16:41:12.465-240" date="10-31-2013" component="SMSPXE" context="" type="1" thread="7840" file="database.cpp:479">
Не всегда говори, что думаешь, но всегда думай, что говоришь

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 12:47

Алексей Максимов писал(а):Если правила не появились, то вполне возможно, что установка WDS в процессе включения PXE в свойствах точки распространения прошла как-то некорректно. Проверьте предположения Виталия, и если у вас режим HTTPS не включен, можно просто попробовать отключить поддержку PXE (при этом согласиться на снос WDS), подождать успешного завершения удаления WDS (отследить по эвентлогам), и заново включить PXE, тем самым инициировав процесс повторной установки WDS.
А все эти правила которые дублируются, я так понимаю можно удалить?
Не всегда говори, что думаешь, но всегда думай, что говоришь

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Алексей Максимов » 31 окт 2013 12:52

Да. Вполне можно удалить.

Аватара пользователя
Toha
Завсегдатай
Сообщения: 33
Зарегистрирован: 31 окт 2013 05:36
Откуда: г. Набережные Челны, РТ
Контактная информация:

Re: Установка Windows 7 по сети

Сообщение Toha » 31 окт 2013 13:04

Папку RemoteInstall которая осталась после WDS я удалю, а вот стоит ли отвязывать все образы и эталоны от DP? Удалить последовательности задач?
Не всегда говори, что думаешь, но всегда думай, что говоришь

Ответить

Вернуться в «System Center Configuration Manager»