Консоль SCCM не запускается

Ответить
mitushinem
Завсегдатай
Сообщения: 25
Зарегистрирован: 20 сен 2013 04:07
Откуда: Смоленск
Контактная информация:

Консоль SCCM не запускается

Сообщение mitushinem » 09 окт 2014 04:50

Добрый день!
Перестала запускаться консоль SCCM 2012 R2.
Выдает вот это
Консоли Configuration Manager не удалось подключиться к базе данных сайта Configuration Manager. Проверьте следующее:

• наличие сетевого подключения этого компьютера к компьютеру поставщика SMS;
• наличие для учетной записи пользователя разрешения на удаленную активацию на сервере сайта Configuration Manager и на компьютере поставщика SMS;
• поддерживает ли сервер сайта версию консоли Configuration Manager;
• назначена ли вам хотя бы одна роль безопасности администрирования на основе ролей;
• наличие следующих разрешений WMI для пространств имен Root\SMS и Root\SMS\site_<site code>: "Выполнение методов", "Запись поставщика", "Включение учетной записи" и "Включение удаленного доступа".
В подробных логах консоли вот это
[1, PID:8000][10/09/2014 09:17:54] :**************** Console: Trace started ****************
[1, PID:8000][10/09/2014 09:17:54] :Found commandline argument: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\bin\Microsoft.ConfigurationManagement.exe, value:
[1, PID:8000][10/09/2014 09:17:54] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[1, PID:8000][10/09/2014 09:17:54] :XML loaded from C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\ConsoleRoot\ConnectedConsole.xml
[1, PID:8000][10/09/2014 09:17:54] :Loading 'AdminConsole' XML
[1, PID:8000][10/09/2014 09:17:54] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[1, PID:8000][10/09/2014 09:17:54] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[1, PID:8000][10/09/2014 09:17:54] :Using Default help system: 'ConfigMgr Help System'
[1, PID:8000][10/09/2014 09:17:54] :Using HelpSystem: 'ConfigMgr Help System
[1, PID:8000][10/09/2014 09:17:54] :Loading help system Assembly; Path='C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\bin\AdminUI.HelpSystem.dll', type='Microsoft.ConfigurationManagement.AdminConsole.Help.SmsHelpSystem'
[1, PID:8000][10/09/2014 09:17:54] :Image count: '1'
[1, PID:8000][10/09/2014 09:17:54] :The performance counter '# images' was not found
[1, PID:8000][10/09/2014 09:17:54] :Loaded icon 'AdminConsole' from assembly 'AdminUI.UIResources.dll'.'Microsoft.ConfigurationManagement.AdminConsole.UIResources.Properties.Resources.resources'
[7, PID:8000][10/09/2014 09:17:55] :The performance counter '# result objects in memory' was not found
[7, PID:8000][10/09/2014 09:17:55] :Establishing connection for 'WQL'
[7, PID:8000][10/09/2014 09:17:55] :The performance counter '# exceptions' was not found
[7, PID:8000][10/09/2014 09:17:55] :Microsoft.ConfigurationManagement.ManagementProvider.SmsConnectionException\r\nКлюч реестра 'Software\Microsoft\Configuration Manager10\AdminUI\QueryProcessors\WQL' не найден\r\n в Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.GetConnectionManagerInstance(String connectionManagerInstance)
в Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.BuildTreeWorker()
в Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.OnExpand(AsyncStatus status)
в Microsoft.ConfigurationManagement.AdminConsole.ConnectingToServerController.workerThread_DoWork(Object sender, DoWorkEventArgs e)\r\nСведения для этой ошибки недоступны.\r\n
[7, PID:8000][10/09/2014 09:17:55] :The performance counter '# result objects in memory' was not found
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :XML loaded from C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\ConsoleRoot\IdleConsole.xml
[7, PID:8000][10/09/2014 09:17:55] :Loading 'AdminConsole' XML
[7, PID:8000][10/09/2014 09:17:55] :XML UnknownNode found: HelpTopic, line: 4, position: 89, ignoring
[7, PID:8000][10/09/2014 09:17:55] :XML UnknownAttribute found: HelpTopic, line: 4, position: 89, ignoring
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :Node 'AdministrationRootName' will be shown
[7, PID:8000][10/09/2014 09:17:55] :Image count: '2'
[7, PID:8000][10/09/2014 09:17:55] :The performance counter '# images' was not found
[7, PID:8000][10/09/2014 09:17:55] :Loaded icon 'Administration' from assembly 'AdminUI.UIResources.dll'.'Microsoft.ConfigurationManagement.AdminConsole.UIResources.Properties.Resources.resources'
[7, PID:8000][10/09/2014 09:17:55] :Node 'Администрирование' created at location msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :XML loaded from C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\ConsoleRoot\IdleNode.XML
[7, PID:8000][10/09/2014 09:17:55] :Loading 'AdminConsole' XML
[5, PID:8000][10/09/2014 09:17:55] :Actions not in cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode', building list.
[4, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[10, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[5, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[4, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[10, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[5, PID:8000][10/09/2014 09:17:55] :Actions returned from cache for node 'msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode'.
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :Root XML Folder read from registry: C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\\XmlStorage\
[7, PID:8000][10/09/2014 09:17:55] :Node 'Администрирование' created at location msscnav://root/Windows/Wunderbar/ConsoleDisplay/IdleNode/DisconnectedAdministrationRoot
[7, PID:8000][10/09/2014 09:17:55] :Loaded icon 'Administration' from assembly 'AdminUI.UIResources.dll'.'Microsoft.ConfigurationManagement.AdminConsole.UIResources.Properties.Resources.resources'
[7, PID:8000][10/09/2014 09:17:55] :Returning child node: 'Администрирование' for parent node 'Администрирование'
[1, PID:8000][10/09/2014 09:17:55] :Image count: '3'
[1, PID:8000][10/09/2014 09:17:55] :The performance counter '# images' was not found
[1, PID:8000][10/09/2014 09:17:55] :Loaded icon 'Critical' from assembly 'AdminUI.UIResources.dll'.'Microsoft.ConfigurationManagement.AdminConsole.UIResources.Properties.Resources.resources'
Версия клиентов 5.00.7958.1401 и на консоль был установлен последний патч. Просто перестала запускаться.
Что можно сделать
Спасибо!

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение Алексей Максимов » 09 окт 2014 07:13

Консоль перестала запускаться на одном конкретном компьютере? На другом компьютере пробовали? На самом сервере SCCM пробовали?

mitushinem
Завсегдатай
Сообщения: 25
Зарегистрирован: 20 сен 2013 04:07
Откуда: Смоленск
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение mitushinem » 09 окт 2014 08:15

Сначала не работала почему то на сервере, но там я сделал.
А сейчас не работает на отдельно стоящей машине

Я заново пересоздал репозиторий wmi и вот это в каталоге sms\bin\x64
mofcomp smsprov.mof
mofcomp smsstub.mof
mofcomp pollprov.mof
mofcomp netdisc.mof
mofcomp cpprov.mof
mofcomp cmprov.mof

После перезагрузки консоль на сервере стала работать и на клиентах.
А на одной все равно не хочет

Еще есть один момент
В логах mssql 2008 r2 с периодичностью в минуту вываливается вот такое сообщение об ошибке

Код: Выделить всё

Ошибка входа пользователя "OASUPIIT\s-CMSrvSQLAcc". Причина: не удалось открыть явно указанную базу данных. [КЛИЕНТ: <local machine>]
Тоже не знаю из за чего.. Эта учетка использовалась при инсталяции sccm

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение Алексей Максимов » 09 окт 2014 09:44

Ну я думаю проблема с SQL наврядле имеет отношение к неработающей консоли на одной конкретной машине. А если на проблемной машине банально выполнить удаление/установку консоли?

mitushinem
Завсегдатай
Сообщения: 25
Зарегистрирован: 20 сен 2013 04:07
Откуда: Смоленск
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение mitushinem » 09 окт 2014 10:01

Пробовал не помагло

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение Алексей Максимов » 09 окт 2014 10:57

А пробовали именно удалить, затем установить или запускали установку "поверх" ? Лучше выполнять полное удаление а затем новую установку. Также можно попробовать выполнить "Восстановление" через оснастку установки/удаления программ
Также можно при подключении в консоли попробовать указать IP вместо имени сервера.

Далее, если внимательно посмотреть представленный лог (как я понимаю это SMSAdminUI) то можно увидеть исключение, вызванное отсутствием ключа реестра Software\Microsoft\Configuration Manager10\AdminUI\QueryProcessors\WQL

Например в этой заметке предлагается скопировать с машины с заведомо работающей консолью этот ключ на проблемную машину.

mitushinem
Завсегдатай
Сообщения: 25
Зарегистрирован: 20 сен 2013 04:07
Откуда: Смоленск
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение mitushinem » 09 окт 2014 11:46

Я все понимаю, варианты написанные Вами я перепробовал еще до того. Ничего не помогло. Поэтому и обратился на форум за советом

Аналогичное решение я находил, но к сожалению не помогло.
Не понимаю вообще в чем может быть дело
Последний раз редактировалось mitushinem 09 окт 2014 11:58, всего редактировалось 1 раз.

Аватара пользователя
Алексей Максимов
Администратор сайта
Сообщения: 419
Зарегистрирован: 14 сен 2012 06:50
Откуда: г.Сыктывкар
Контактная информация:

Re: Консоль SCCM не запускается

Сообщение Алексей Максимов » 09 окт 2014 12:38

Странно. Но ведь исключение в логе явно говорит об отсутствии ключа реестра. Вы проверяли наличие этого ключа? Сверяли его содержимое с другим компьютером (на котором консоль работает исправно)? Сверяли разрешения на указанный ключ реестра?

Ответить

Вернуться в «System Center Configuration Manager»